// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((\d+),0,'(([^']|\\')+)',0").unwrap();
let string = "(500,0,'ABC',4),(550,0,'ABC',0),(450,0,'D\\'E,F',0),(650,0,'G_HI',0);";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}