use strict;
my $str = 'visite12345
--> is a good anwser (the string does match)
visite1a
--> is not a good anwser (the string doesn\'t match)
visite12345a
--> It doesn\'t work.the output is visite1234, whereas I\'d like to get the same answer that for visite1a (string doesn\'t match';
my $regex = qr/^visite\d+\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}