using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w0-1P(?!.*--)[\w-]*$";
string input = @"R0-1P-10-8--F--YH-
10-1Pabc--
10-1P-3E-Q-
D0-1P
D0-1P-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}