use strict;
my $str = 'R0-1P-10-8--F--YH-
10-1Pabc--
10-1P-3E-Q-
D0-1P
D0-1P-';
my $regex = qr/^\w0-1P(?!.*--)[\w-]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}