$re = '/^(\+?1\ ?)?\(?[0-9]{3}\)?\-?\ ?[0-9]{3}\-?\ ?[0-9]{4}$/m';
$str = '+13178696932
3178696932
13178696932
11231234
1231234
3178696932
8696932
317-869-6932
+1(317)869-6932
+1 (317)869-6932
+033178696932
13178696932
23178696932
+43 720 884555
+1 317 869 6932
317-869-6932
+1(317)869-6932
+1317123456
(317) 869-6932
(555) 555-5555
+1(555) 555-5555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);