# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{4}(?!$)/$&-/gm;t' <<< "1111222233334444
111122223333444
11112222333344
1111222233334
111122223333
11111
9999"