$re = '/\d{4}(?!$)/m';
$str = '1111222233334444
111122223333444
11112222333344
1111222233334
111122223333
11111
9999';
$subst = "$&-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;