package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z$]+\d+(?::[A-Z$]\d+)?`)
var str = `=A$13:B4+$BC$12+$DE2+F2:G2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}