re = /^(Apple2\b.*)$/m
str = 'Apple1:Banana1:Pear1
Apple2:Banana2:Pear2
Apple3:Banana3:Pear3
Apple22:Apple24:Pear2
Apple2s:Apple24:Pear2
Apple22:Apple2:Pear2
Apple22:Apple2:Pear2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end