re = /ж[аоые]лезн[оыа][йи]?[ая] дв[ие]рь/
str = 'жылезныйя дверь
жылезныия дверь
жылезныя дверь'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end