$re = '/feed the (cat|dog|bear)/m';
$str = '"feed the cat."
"feed the dog."
"feed the bear."
"feed the eagle."
"feed the monkey."
"feed the donkey."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);