re = /[^\p{L}\p{N}._-~]+/m
str = 'զվարճ?անք9879#jhkjhkhl!kjljlkjlkjj()+======\\_ew.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end