$re = '/^()()((\[[^\]]*\]))\s*->(.*)/m';
$str = '[AAA] -> [BBB] -> [CCC]
AAA -> [BBB] -> [CCC]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);