# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=^[A-Z]{3}[0-9]{2}[A-Z0-9]{8}[0-9]{2}$)
helloJellofellow
600566604081/600566604081/;t' <<< "hel01Jeloofel10
"