using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(((\/\/|#)[^\n]*\n*)|(\/\*((?!\*\/)(.|\n))+\*\/)|\s)*\s*(\$|echo|class\s+\w|\/\/php|#php|mysql_|namespace|use|include|require|function\s+[^\(\s]+\s*\(\s*\$|((if|while|for|switch|foreach)\s*\(\s*\$\w))";
string input = @"// nějaké podmínky
if($sel->ulcp != $ulcp){$co .= "", ulcp = '$ulcp'"";}
if($sel->ulcp2 != $ulcp2){$co .= "", ulcp2 = '$ulcp2'"";}
if($sel->ulcp3 != $ulcp3){$co .= "", ulcp3 = '$ulcp3'"";}";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}