package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`data-reveal="(.+)`)
var str = `<a class="button block left icon-phone" data-reveal="\u06f0\u06f9\u06f3\u06f6\u06f5\u06f6\u06f8\u06f1\u06f6\u06f2\u06f1" href="#">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}