import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-N,P-Z,0-9]){6}\\.([A-N,P-Z,0-9]){5}\\.(LE|SL|ME|BR|SP)\\.[0-9]{3}$";
final String string = "ADN123.FG4FE3.LE.999";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}