const regex = /^([A-N,P-Z,0-9]){6}\.([A-N,P-Z,0-9]){5}\.(LE|SL|ME|BR|SP)\.[0-9]{3}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-N,P-Z,0-9]){6}\\.([A-N,P-Z,0-9]){5}\\.(LE|SL|ME|BR|SP)\\.[0-9]{3}$', '')
const str = `ADN123.FG4FE3.LE.999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}