// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([A-N,P-Z,0-9]){6}\.([A-N,P-Z,0-9]){5}\.(LE|SL|ME|BR|SP)\.[0-9]{3}$").unwrap();
let string = "ADN123.FG4FE3.LE.999";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}