$re = '/(?:<a href="|\G)\S*\K (?=[^">]*")/';
$str = '<a href="file with spaces.mp3">file with spaces.mp3</a>';
$subst = "%20";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;