re = /^(([^,\n]*,){4}[^,\n]*).*/m
str = 'movie/spiderman,genre/action,movie:marvel
movie/kingsman,genre/action
movie/spiderman,genre/action,movie:marvel,movie:dfjkl,movie:fskj,movie:aa,movie:mdkk'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result