package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?|([aeiou]+)[0-9]+|([123]+)[a-z]+)\W+`)
var str = `ae123.
111abc!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}