package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([!@#$%^&*]+|\d+|[a-zA-Z]+)$`)
var str = `aaa
123
@#$
a12qw
a@s
123$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}