Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(.*?),(.*)
"
gm
Test String
New
Geranium, Ivy Geranium, Zonal Geranium, Interspecific Impatiens, New Guinea Petunia, Trailing Petunia, Spreading Petunia, Miniature Trailing Impatiens, Interspecific New Guinea Mum, Garden Mum, Pot Combinations, Vigorous
Substitution
Processing...
\2 \1