const regex = new RegExp('(.*?),(.*)', 'gm')
const str = `Geranium, Ivy
Geranium, Zonal
Geranium, Interspecific
Impatiens, New Guinea
Petunia, Trailing
Petunia, Spreading
Petunia, Miniature Trailing
Impatiens, Interspecific New Guinea
Mum, Garden
Mum, Pot
Combinations, Vigorous`;
const subst = `\2 \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);