import re
regex = re.compile(r"(.*?),(.*)", flags=re.MULTILINE)
test_str = ("Geranium, Ivy\n"
"Geranium, Zonal\n"
"Geranium, Interspecific\n"
"Impatiens, New Guinea\n"
"Petunia, Trailing\n"
"Petunia, Spreading\n"
"Petunia, Miniature Trailing\n"
"Impatiens, Interspecific New Guinea\n"
"Mum, Garden\n"
"Mum, Pot\n"
"Combinations, Vigorous")
subst = "\\2 \\1"
result = regex.sub(subst, test_str)
if result:
print(result)