const regex = /ONToday@javascript:gs\.beginningOfToday\(\)@javascript:gs\.endOfToday\(\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ONToday@javascript:gs\\.beginningOfToday\\(\\)@javascript:gs\\.endOfToday\\(\\)', 'gm')
const str = `active=true^opened_by=6816f79cc0a8016401c5a33be04be441^ORassigned_to!=6816f79cc0a8016401c5a33be04be441^short_descriptionISNOTEMPTY^NQopened_atONToday@javascript:gs.beginningOfToday()@javascript:gs.endOfToday()^EQ`;
const subst = ` is today `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);