re = /(?:(\((?:[^()]++|(?1))*\))|'[^']*')(*SKIP)(*F)|([+\-*\/^])/m
str = '1 + 2 * (3 + (23 + 53 - (132 / 5) + 5) - 1) + 2 / \'test + string\' - 52
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end