using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\s\+?(\(?[0-9]+\)?\s?)+";
string input = @"tel/mob: 001 433 123 4352
tel/mob: 0014331234352
tel: 001 433 123 4352
tel: 0014331234352
tel/mob: 001 (433) 123 4352
tel: 001 (433) 123 4352
tel/mob: +1 433 123 4352
tel/mob: +14331234352
tel: +1 433 123 4352
tel: +14331234352
tel/mob: +1 (433) 123 4352
tel: +1 (433) 123 4352";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}