import Foundation
let pattern = #":\s\+?(\(?[0-9]+\)?\s?)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
tel/mob: 001 433 123 4352
tel/mob: 0014331234352
tel: 001 433 123 4352
tel: 0014331234352
tel/mob: 001 (433) 123 4352
tel: 001 (433) 123 4352
tel/mob: +1 433 123 4352
tel/mob: +14331234352
tel: +1 433 123 4352
tel: +14331234352
tel/mob: +1 (433) 123 4352
tel: +1 (433) 123 4352
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)