using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mr abdul alim m2a";
string input = @"ça va?";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}