use strict;
my $str = '«el taller del traductor"';
my $regex = qr/(«[a-z])/p;
my $subst = '\\U$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";