$re = '/(\G(?!^)|\b[a-zA-Z][a-z]*)([A-Z][a-z]*|\d+)/';
$str = 'FfdffDF
firstLine(874),
secondLine(15),
thirdLineOfText87(0x0001);
ThirdLineOfText87(0x0001);';
$subst = "\U\1_\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;