package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+-(?<your_field>.*)`)
var str = `abc-ec-1
xyz-ec-01
pqr-ec01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}