#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((:?\D\d)+|(:?\d\D)+)$"
Local $sString = "H1e2l3l1" & @CRLF & _
"Hello" & @CRLF & _
"Hel1lo" & @CRLF & _
"a1b2c3d4" & @CRLF & _
"1b2c3d4e"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")