package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^((:?\D\d)+|(:?\d\D)+)$`)
var str = `H1e2l3l1
Hello
Hel1lo
a1b2c3d4
1b2c3d4e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}