import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\b(?:soy|almond)\\s*(?:milk)?)\\bmilk\\b";
final String string = "\"...almondmilk...\" = no match\n"
+ "\"...almond milk...\" = no match\n"
+ "\"...almond word(s) milk...\" => matched ['milk']\n"
+ "\"...almondword(s)milk...\" => matched ['milk']\n\n"
+ "\"...soymilk...\" = no match\n"
+ "\"...soy milk...\" = no match\n"
+ "\"...soy word(s) milk...\" => matched ['milk']\n"
+ "\"...soyword(s)milk...\" => matched ['milk']\n\n"
+ "is combined with creamy soy and milk. a fruity and refreshing sip of spring,\n"
+ "is combined with creamy milk. a fruity and refreshing sip of spring, \n\n"
+ "\"...milk...this is soy milk and regular milk\" ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}