$re = '/^([\w+-.])+@([\w-.])+.([A-Za-z]{2,64})$/i';
$str = 'test@example.email';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);