$re = '/^(.*)(-)(\d{1})(.[^.]+)$/m';
$str = 'P123456_1_flying-elephant-100x70-1.pdf';
$subst = "\1\20\3\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;