$re = '/^if *\(([^:]+)\): ([^:]+) (?::else: ([^:]+) )?endif$/m';
$str = 'if(stat(life) >= 2): deal_damage(5) endif
if(stat(life) >= 2): abc(5) deal_damage(5) :else: gain_block(5) endif
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);