using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[localhost|http|https|ftp|file]+://[\w\S(\.|:|/)]+";
string input = @"Hello www.google.com World http://yahoo.com";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}