re = /[localhost|http|https|ftp|file]+:\/\/[\w\S(\.|:|\/)]+/
str = 'Hello www.google.com World http://yahoo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end