$re = '/"([^"]+)"/m';
$str = 'string(10) "CURITIBA" string(11) "SP"
fasdjask fsjkasjdklfklasdjflasdjklçfjasklç as"fasd fasd fasdasdfasdfasdfasdfasfasdfasdfasdfasfasdfasdfasdfasdfasdfasfsadfasdffas" fas asfd
fasdfasdfjklasdfklçasdjklf jlasdjfklasdj klfj asdlkçfj klasdçfasd
ESTA ASPAS NÃO FECHA: "fasdklfasdkljfklasjflkasjklfjasklfjasdklfjasfsdjklafjasdklfjklsadjfklasjlfjasdlfjaskljfklasjfasklçjkfasfsdafasdfasdfdlasdfdasfsdafadfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasdfasfasdfasdfasdfasfasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);