re = /(https?:\/\/)?github\.com\/(?<author>[\w-]+)\/(?<repo>[\w-]+)\/?(tree\/)?(?<branch>[\w-]+)?/m
str = 'https://github.com/richardwilkes/gcs/tree/master'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end