import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*\\bOptional\\b.*\\s=\\s.*|(?!.*\\bOptional\\b).+)";
final String string = "Optional str1 as string = ''\n"
+ "str2 as string\n"
+ "str3 as boolean, Optional dtm as date = Now\n"
+ "str3 as boolean, Optional dtm as date Now";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}