package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Advogado\:\s)(.+?)(Número\sdo\sProcesso\:\s)(.+?)(OutroCampo\:\s)(.+?)$`)
var str = `Advogado: XXXXX Número do Processo: XXXXXX OutroCampo: XXXXX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}