# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}/$1/g;t' <<< "{eggs:ce_img:single
src=\"{src}\"
fallback_src=\"/assets/a-b-c.jpg\"
width=\"250\"
height=\"250\"
add_dims=\"no\"
crop=\"yes\"
title=\"{title}\"
alt=\"{title}\"
allow_scale_larger=\"yes\"
}"