#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:^|\n\d+\))[^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*(?:(?<=\D)\)|\([^)]*$)"
Local $sString = "Текст текст текст. Список:" & @CRLF & _
"" & @CRLF & _
"1) пункт первый" & @CRLF & _
"2) пункт второй" & @CRLF & _
"3) пункт третий" & @CRLF & _
"228) наркопункт" & @CRLF & _
"1337) элитный пункт" & @CRLF & _
" Текст (текст (в (скобках) ещё (текст) в) скобках) текст." & @CRLF & _
"1488) наципункт" & @CRLF & _
"" & @CRLF & _
"Скобкодаун тешится)))" & @CRLF & _
"Скобкодаун грустит((("
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")