use strict;
my $str = 'Текст текст текст. Список:
1) пункт первый
2) пункт второй
3) пункт третий
228) наркопункт
1337) элитный пункт
Текст (текст (в (скобках) ещё (текст) в) скобках) текст.
1488) наципункт
Скобкодаун тешится)))
Скобкодаун грустит(((';
my $regex = qr/(?:^|\n\d+\))[^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*(?:\([^)(]*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*\)[^)(]*)*(?:(?<=\D)\)|\([^)]*$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}