#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((\d{4}).(\d{2}).(\d{1}).(\d{1,3}).(\d{1,3}))"
Local $sString = "2018.30.3.0.4" & @CRLF & _
"SS.InSite-2018.30.3.0.4" & @CRLF & _
"2018.30.3.0.4" & @CRLF & _
"2018.30.3.0.4 " & @CRLF & _
"2018.30.3.0.4TEst" & @CRLF & _
"20181.30.3.0.4" & @CRLF & _
"2018.301.3.0.4 " & @CRLF & _
"2018.30.3.0.4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")